Краткий обзор Microsoft Office 2003



Копирование формул


Копирование формул производят по тем же правилам, что и копирование данных листа. Ниже рассмотрены различные методы копирования формул.

Копирования формулы методом перетаскивания


Приведем пример копирования формулы методом перетаскивания. Предположим надо возвести в третью степень числа 5, 7 и 10, которые находятся в ячейках A3, А4 и А5. Результаты вычислений запишем соответственно в ячейки ВЗ, В4 и В5. Выделим ячейку ВЗ и введем в нее формулу =АЗА3 (символ «Л» используется как оператор возведения в степень). Нажмем клавишу Enter. В ячейке появится результат 125. Выделим еще раз ячейку ВЗ. Установим указатель мыши на маленький черный квадратик — маркер заполнения. Нажмем кнопку мыши и растянем рамку еще на две ячейки вниз. В выделенных ячейках отобразятся результаты вычислений: 343 и 1000. Щелкнем ячейку В4 — в строке формул увидим =А4Л3, т.е. относительный адрес ячейки изменился.
Если при копировании формулы необходимо оставить ее адрес неизменным, то используется абсолютная ссылка. Напишем формулу в виде =$А$3^3.
При копировании этой формулы в любое место таблицы всегда будут возведены в третью степень данные, находящиеся в ячейке A3.
Копирование формул с помощью команды Копировать в меню Правка
Чтобы скопировать формулу, выделите ячейку с формулой и выберите в меню Правка (Edit) команду Копировать (Сору). Затем выделите ячейку или диапазон ячеек, куда будет вставлена формула, и выберите команду Вставить (Insert) в меню Правка (Edit). Ячейки, в которые копируется формула, могут находиться на другом листе или в другой книге.

Копирование формул с помощью команды Заполнить в меню Правка


При повторных вычислениях по одним и тем же формулам можно воспользоваться еще одним способом копирования формул — командой Заполнить (Fill) в меню Правка (Edit). В качестве примера используем эту команду для нахождение среднего арифметического значения данных по столбцам в ячейках В10 и В11, С10 и С11, D10 и D11 (рис. 16.10).

  •  Введем в ячейки исходные данные.
  •  Поставим курсор в ячейку В12 и выберем команду Функция (Function) в меню Вставка (Insert).
  •  В диалоговом окне Мастер функций — шаг 1 из 2 (Insert Function) (рис. 16.6) в списке Категория (Function category) в раскрывающемся списке Категория выберем строку Статистические (Statistical), в списке Выберите функцию (Select a function) элемент СРЗНАЧ (AVERAGE) и нажмем кнопку ОК. В диалоговом окне Аргументы функции (Function Arguments) (рис. 16.6). Мастер функции предложит найти среднее арифметическое значения в ячейках В10:В11. После нажатия кнопки ОК в ячейке В12 появится результат.



Рис. 16.10 Копирование формул с помощью команды Заполнить в меню Правка

  •  Выделим ячейки В12, С12 и D12.
  •  Выберем в меню Правка (Edit) команду Заполнить (Fill), Вправо (Right).


Формула из ячейки В12 скопируется в ячейки С12 и D12 и мы увидим результаты вычислений. Если в ячейке В12 находилась формула =СРЗНАЧ(В10:В11) (AVERAGE)(B10:B11), то в ячейках'С12 и D12, она примет соответственно вид =СРЗНАЧ(С10:С11) и =CP3HA4(D10:D11).