Краткий обзор Microsoft Office 2003

https://kakoysegodnyaprazdnik.com/prazdniki-12-aprelya.html


Ввод формулы в ячейку


Для ввода формулы в ячейку выделите ее и введите в строку формул или в ячейку знак «=».
При переходе в режим ввода формул поле Имя (Name), расположенное в левой части строки формул, заменяется кнопкой, на которой отображена последняя использовавшаяся функция. Расположенная справа от нее кнопка со стрелкой открывает список, который содержит 10 последних использовавшихся функций и пункт Другие функции (More/unctions) (рис. 16.1).



Рис. 16.1 Окно Excel в режиме ввода формул

В качестве примера введем формулу в ячейку D4. Закончив ввод формулы, нажмем клавишу Enter или щелкнем в строке формул по кнопке Ввод (Enter). В ячейке, содержащей формулу, отобразится результат вычисления, сама формула будет видна в строке формул (рис. 16.2).



Рис. 16.2 Отображение расчетной формулы в строке формул

Использование ссыпок в формуле


Формула может содержать ссылку на ячейку (ее адрес) или на диапазон ячеек, а также на имена, представляющие ячейки или диапазоны ячеек. Для описания ссылок на диапазоны ячеек используются операторы, приведенные в таблице 16.3.

Таблица 16.3. Операторы ссылки


Операторы ссылки

Значение (пример)

: (двоеточие)

Ставится между ссылками на первую и последнюю ячейки диапазона. Такое сочетание является ссыпкой на диапазон (В5:В15).

; (точка с запятой)

Оператор объединения. Объединяет несколько ссылок в одну ссылку (СУММ(В5:В15;О5:В15)).

(пробел)

Оператор пересечения множеств, служит для ссылки на общие ячейки двух диапазонов (B7:D7 С6:С8).


Чтобы сослаться на диапазон ячеек, введите ссылку на верхнюю левую ячейку диапазона, поставьте двоеточие (:), а затем — ссылку на правый нижний угол диапазона. Например, А2:С5. Ссылка на все ячейки между 6-й и 15-й строками включительно имеет вид 6:15, на все ячейки в столбце С — С:С.
Для задания обращения ко всем ячейкам, находящимся в нескольких диапазонах одновременно используется пересечение. Для задания пересечения диапазонов используется пробел. Например, формула =СУММ(А2:ВЗ В2:СЗ) вычисляет сумму чисел в пересекающихся диапазонах А2:ВЗ и В2:СЗ. Для обращения ко всем ячейкам, включенным в два диапазона, используется объединение. Если в ячейке ВЗ записано Петров, а ячейке A3 — Владимир, то формула АЗ=ВЗ&", "&АЗ будет означать объединение указанных выше имен, разделенных запятой (Петров, Владимир). При использовании операторов объединения и пересечения удобно пользоваться именованными диапазонами.
В формулу можно вводить ссылки на ячейки различных рабочих листов и книг. Ссылки, распространяющиеся на несколько рабочих листов, называются трехмерными. Ячейка, содержащая формулу, называется зависимой ячейкой. Ее значение зависит от значений ячеек, на которые имеются ссылки в формуле.
Примеры записей диапазонов ячеек в функции:

  •  =СУММ(Е:Е) — определяется сумма числовых значений, содержащихся в столбце Е;
  •  =СУММ(Е2:С5) — подсчитывается сумма числовых значений, расположенных в диапазоне от Е2 до G5;
  •  =СУММ(5:5) — суммируются данные всех ячеек пятой строки;
  •  =СУММ(2;4) — подсчитывается сумма 2+4.


Допускается смешанная запись адресов ячеек и блоков ячеек. В этом случае формула может выглядеть следующим образом:
=СУММ(С8;О4;Е2:Е5;Р5)

Ввод в формулу ссылок на ячейки с помощью мыши


Так, если вам необходимо после знака = в формуле дать ссылку на ячейку А4, щелкните на этой ячейке мышью, вокруг ячейки появится бегущая рамка, а в формуле отобразится ссылка на эту ячейку. Для ввода ссылки на диапазон ячеек щелкните по угловой ячейке диапазона и, удерживая нажатой кнопку мыши, перетащите указатель в противоположный угол для выделения всего диапазона.

Отображение формулы в ячейке


При стандартной настройке в ячейке с формулой отображается результат вычислений, а не сама формула. В некоторых случаях, например, при составлении и проверки сложных расчетов в ячейке удобнее отображать не числовое значение, а саму формулу.
Для возврата к принятому режиму отображения формул снимите флажок. . Чтобы перейти в режим отображения формул или вернуться в обычный режим нажмите клавиши Ctrl+' (клавиша обратного апострофа находится на той же клавише, что и тильда «~» — ниже клавиши Esc).

Подсказки аргументов функций


При создании новой формулы в Excel отображается информация об аргументах функции. Кроме того, всплывающие подсказки обеспечивают быстрый доступ к нужным разделам справки. Пользователю достаточно щелкнуть мышью имя любой функции или аргумента, отображаемых во всплывающей подсказке.

Абсолютная и относительная ссылка


Ссылка — это указание адреса ячейки. Различают относительные или абсолютные ссылки.
Например, нам надо подсчитать сумму чисел, хранящихся в ячейках Al, A2, A3. Щелкнем дважды ячейку А5, и поместим в нее формулу=А1+А2+АЗ. Чтобы вычислить сумму чисел, хранящихся в ячейках Cl, C2, СЗ, можно не писать заново формулу, а скопировать ее из ячейки А5 в G5 (см. главу 14, раздел «Копирование и перемещение содержимого ячеек»). Excel автоматически изменит относительные ссылки и формула примет вид =С1+С2+СЗ. Измененную формулу можно увидеть, щелкнув ячейку С5. (Для отображения формул в окне приложения установите флажок формулы на вкладке Вид диалогового окна Параметры (рис. 19.8).)
Например, если скопировать формулу из ячейки А7 с абсолютными ссылками в ячейку С7, то формула не изменится. Для указания абсолютной ссылки используется знак доллара $. $А$7, $С$7 (рис. 16.3). Адреса ячеек, использованные в формуле, и границы этих ячеек будут закрашены в одинаковые цвета.



Рис. 16.3 Отображение формул с абсолютными, и относительными ссылками в окне Excel

В тех случаях, когда при копировании или перемещении формулы необходимо сохранить неизменным только номер строки или только наименование столбца, применяют смешанную ссылку, например $D7 или F$5. Более подробно использование абсолютной ссылки в формуле рассмотрено ниже в разделе «Копирование формулы».

Внешние и умаленные ссылки


Можно ссылаться на ячейки, находящиеся на других листах книги или в другой книге, или на данные другого приложения. Ссылки на ячейки других книг называются внешними ссылками. Ссылки на данные других приложений называются удаленными ссылками.

Смарт-тег проверки ошибок


0 возможной ошибке в ячейке пользователя оповещает смарт-тег проверки ошибок. Пользователю предлагается исправить ошибку, пропустить ее или получить доступ к дополнительным параметрам средства проверки ошибок. Попробуйте вычислить сумму по столбцу, пропустив последнюю ячейку группы. Наведите указатель на ячейку, содержащую сумму, чтобы отобразились варианты, предлагаемые функцией проверки ошибок.

Панель аудита формул


Панель аудита формул предлагает ряд элементов управления для доступа к функциям аудита, таким как средство проверки формул и окно контрольного значения. Данная функция позволяет выполнить вычисление по шагам и понять, каким образом получается итоговый результат. Она также предоставляет некоторые дополнительные возможности, например переключение в режим отображения всех формул на листе.
Для проверки вычислений в формулах выделите ячейку, которую необходимо проверить. Откройте панель аудита формул и нажмите кнопку Вычислить формулу ().